Talk:Ultima IV: Quest of the Avatar

From Ultima Codex
Jump to: navigation, search

Default reagents[edit]

Hiya all,

I've got a quick question for people who played the original Ultima 4.

I'm just trying to wrap up my Flash game and I got a comment from somebody who told me that player characters usually started the game with a couple of reagents: garlic, and ginseng.

This way the player can mix any cure spells that they might need from wandering around in swamps.

Can someone confirm this for me? Was this perhaps a console version thing... or perhaps it's been sooooo long since I started a character in the old game that I've completely forgotten about it.

Cheers to anyone and everyone who can help,

WebMonkey741 23:17, May 18, 2010 (UTC)WebMonkey741

Tested it with a Paladin on the PC. Got 4 Garlic and 3 Ginsing to start with. So the information seems to be correct.--Tribun 23:21, May 18, 2010 (UTC)
true, even if you are a fighter or shepherd who can't cast spells. mightyschoop

A Further Question[edit]

Thanks for the update. Do you know if those values are consistent, or are they randomly generated on start-up?

Plus, could you test what happens if you use up the reagents and then die??? Do you get another batch when you restart at LBC?

Thanks for all your help on this,

WebMonkey741 23:31, May 18, 2010 (UTC)WebMonkey741

The reagents are the same for all classes. When you die, you keep 300 food and 200 gold. You will keep EQUIPPED weapons and armor, as well as QUEST items and spells that you have already mixed. Everything else, and that includes reagents, is lost. This is why dying is a pain in the ass.--Tribun 23:52, May 18, 2010 (UTC)
What version of Ultima IV do you play Tribun? On the PC after dying I get 200 food and 200 gold and I keep all my reagents. I also keep equipment (i.e. torches, gems and sextant). -- Fenyx4 18:49, September 15, 2010 (UTC)

Original Sound Effects[edit]

Ok so here's my new question for people who have played the original Ultima 4.

What were the in-game original sound effects?

So far I've been able to figure out the following:

  • Walking (when your party icon moved around)
  • Horse Trot / Gallop (when your party was on a horse and moving around)
  • Attack (when a character/monster attacks in combat)
  • Damage (when a character/monster takes damage)
  • Tremor (sound when tremor was cast or any other time the screen shook)
  • Healing (sound when getting healed in town)
  • Level Up (sound when LB raises a character a level)
  • Moongate (sound when going through a moongate)
  • Cannon Fire (sound when shooting a ship's cannon... or was this the same as attack?)
  • Spell (sound made when casting a spell)


Was there anything else? Any help that people could provide would be greatly appreciated.

Cheers,

75.157.172.63 18:58, May 29, 2010 (UTC)WebMonkey

For a totally exhaustive list (but not all the sounds themselves), I'd download xu4 and take a look at the .xml file in the package that has the list. I'd go off the top of my head but I know I would forget some. --Polygoncount 19:01, May 29, 2010 (UTC)

Fair enough... but I just wondered if anybody remembered from the original game. I played on an Apple IIe and I think things were a little different between the C64 version. Also, I don't know which sounds might have been added when they did xu4. But you might be right... I can just review the sound list XML and go from there... THANKS! WebMonkey741 19:19, May 29, 2010 (UTC)WebMonkey741


Well I looked through the xu4 files and here's what I found:

  • Blocked
  • Error
  • Evade
  • Flee
  • Magic
  • NPC_Attack
  • NPC_Struck
  • PC_Attack
  • PC_Struck
  • Poison_Damage
  • Poison_Effect
  • Title_Fade
  • Walk_Combat
  • Walk_Normal
  • Walk_Slowed


This is a good list. But I do remember there being different sounds for when you are travelling on a horse. Also, I remember there being sounds for getting healed and gaining a level.

I think I could probably merge my memories list with the xu4 list and do just fine... but if anyone has anything else that they remember from playing then PLEASE add to this list.

Thanks again,

WebMonkey741 19:44, May 29, 2010 (UTC)

Various editorial opinions[edit]

There are several opinions in the article which may or may not be appropriate. These are the ones I'm thinking about. They are all in or after the "Differences between platforms" section:

  1. "the introduction sequence and dungeons looked better on the Amiga and Atari ST" Maybe it's clearly true, but I can't verify that
  2. "although the graphics aren't as simplistic" Are they clearly not?
  3. "is suprisingly accurate and has good graphics and sound" Actually, I'm almost certain that this isn't appropriate, not unless someone produces a very involved case defending it.
  4. "with obvious limitations only on conversations" Why "obvious"?
  5. "Ultima IV was a sensation in 1985. Because of its unique story, it sold very well and inspired many other developers." this is quite probably true, but I'd feel more comfortable if there was a reference to accompany it.

AngusM 05:56, September 15, 2010 (UTC)


Those "Differences between the ports" sections in general do tend to get rather editorialized. I think there have been some recent efforts to clean them up, so I'd be more than happy to see more neutral language used here. --Terilem 06:08, September 15, 2010 (UTC)


I've just tackled the "graphics aren't as simplistic" section in the NES port by having it point out that the graphics are another culture (Japan)'s style instead... I'll go back and see what I can do with the rest when/as I can. --☥ Xyzzy ☥ 01:50, 7 January 2011 (PST)

Being ejected back to the surface[edit]

Sure, it's quite likely that "in early Apple versions, if you answered the questions in the Abyss incorrectly, you are ejected back to the surface." but I seem to remember the same thing happening to me when I played the DOS version. That doesn't make the line incorrect, but does make it misleading. Does anyone know more about this? AngusM 05:58, September 15, 2010 (UTC)

Just tried it on the first level of the Abyss and it doesn't eject you back to the surface. This one even has a reference! -- Fenyx4 06:31, September 15, 2010 (UTC)
If you answer the questions incorrectly on the 8th level though, you will be kicked back to the surface. I'm almost certain I remember that happening to me in the PC version. Dungy 10:43, September 15, 2010 (UTC)
I went and checked. It gave me three chances before kicking me out. And here's the quote from the magazine;
So, here you are (what's left of you) at the
Codex door. Is it over? Not quite. Now, you have
to prove you're an Avatar... as though everything
you've been through wasn't enough! You have to
answer twelve questions before you can read the
Codex... and you had better be right the first time
you answer each one. This is especially true for the
early Apple versions. If you give a wrong answer,
or make a typo, you will be kicked out of the
Abyss entirely, and you will have to go through it
all over again, the whole eight levels (scream). Lord
British is making a change to this for future versions
(which may be out by the time you read this),
and you'll get a second chance if you blow it the
first time. However, just to be on the safe side (if
there is such a thing), take your time, and answer
each question carefully... very carefully!
I changed the trivia to catch the key point. -- Fenyx4 16:16, September 15, 2010 (UTC)
I definitely played the PC version. I don't remember being given 3 chances. Now that I've thought about it some more, I do remember being ejected twice. I doubt this would have happened after having being given 6 chances. AngusM 16:36, September 15, 2010 (UTC)
Well, having just played through to the bottom of the Abyss myself I wholeheartedly encourage you to do the same and prove me wrong. :)
But next time I'm down there, just to be sure, I'll do a more thorough test as I did stop after getting kicked out by answering the word of passage one incorrectly three times and there are more questions after that and they might be different. -- Fenyx4 16:55, September 15, 2010 (UTC)
There are a lot of questions, aren't there? Even at level 8 alone. As I recall, the questions that identify each Virtue were the most ambiguous, so I probably failed on those. DosBox can now save state, can't it? Perhaps I should go down there and try to put every question through a stress test. Unfortunately, I don't have the version I had 15 years ago. Did you patch the version you tried, Fenyx? AngusM 17:32, September 15, 2010 (UTC)
Mine should be unpatched. Copied from computer to computer and is originally from this version. -- Fenyx4 17:54, September 15, 2010 (UTC)
In that case, can you pass me your save game, w/you standing outside the Abyss? Thanks. AngusM 19:01, September 15, 2010 (UTC)
Savegame. You should be standing right at the end of the game. -- Fenyx4 07:17, September 19, 2010 (UTC)

Beating Ultima IV without the silver horn[edit]

Not trying to start an edit wat with you Sergorn, but it is possible to beat Ultima IV without the silver horn. I've done it. It means when you approach the shrine of humility, you are going to have to fight a LOT of daemons, but the Avatar and friends only get attacked after moving, so since the terrain is hilly, you're only going to successfully move forwards like 1 in every 2 or 3 tries, which means 3 tough battles for every one space moved forwards, but it IS possible to reach the shrine without the horn. The first time I played Ultima IV, I was unable to find the horn, so I thought that was actually the only way of doing it.. Dungy 23:19, October 7, 2010 (UTC)

I believe I did it the first time without the Silver Horn by exploiting the balloon bug in the Apple II version (which lets you "X-it" the balloon while it is in flight, anywhere, and monsters still behave as though you are flying). I never successfully fought my way past the daemonic hordes. --Polygoncount 23:34, October 7, 2010 (UTC)
It's more complicated than that though - as I mentioned in article the french version of Ultima IV doesn't allow you to use *any* item. So you can't use the stones on altar to get the three part key, you can't use the bell, book and candle to open the Abyss, you can't use Mondain's skull to destroy it on so on. Which is why it is impossible to complete the game since you do need to use items to finish it. I guess some rephrasing is in order then --Sergorn 23:36, October 7, 2010 (UTC)
Ahh... that's a whole different story. Rephrasing is in order then.. Dungy 23:52, October 7, 2010 (UTC)


Computer Gaming World[edit]

By the way, the scan project http://www.cgwmuseum.org/index.php finished, so every referenced article is now online ... if someone wants to link the scans / if this is actually allowed?

Spam Filter[edit]

After I put on a picture of the C64 special edition box in the Computer Ports of Ultima IV page and saved the page I got this:

...you wanted to save was blocked by the spam filter. This is probably caused by a link to a blacklisted external site.

The following text is what triggered our....600 and forty-two.jpg or forty-one.jpg(Sorry, I have to do this way or else it will block again.) Is this normal? --Arthgon 05:50, 28 December 2012 (PST)

We had a huge rash of spam where the only thing similar between them was the naming scheme of the images. So I filtered out anything with ###.jpg or ####.jpg. As we typically use pngs and don't have high numbered files it hasn't been an issue. I'd recommend renaming the file. Perhaps c64-2.jpg or c64-1.jpg? -- Fenyx4 06:56, 28 December 2012 (PST)
That's very odd, because the file that I have put there was File:U4c643.PNG Even though it's now changed and revised into File:Ultima4Europe.jpg by Tribun, it still saying the same thing. It is also happening when I change C64 title screen into C64 Title Screen OR something else. --Arthgon 07:14, 28 December 2012 (PST)

Even odder is, I was able to edit the page without trouble. Maybe the problem has more likely something to do with your computer?--Tribun 07:21, 28 December 2012 (PST)

I rebooted my computer and tried again. (I must have overlooked the fact that you already placed it there. Sorry.) As you can see it works perfectly everywhere except where it should be: Computer Ports of Ultima IV. It seems that it have to do with other two jpg in The C64-Port. Interesting, not all other ports has this problem at all. --Arthgon 08:03, 28 December 2012 (PST)

I see it now, it really seems to be the fact that the picture's last three letters were digits. Fenyx, since you already are blocking spammers with the admin permission, could you please remove the filter? It has lost its use, since accounts now have to be approved.--Tribun 09:06, 28 December 2012 (PST)

Another option is to change their names and into PNG. --Arthgon 09:51, 28 December 2012 (PST)
Hmm, odd that it is working in some places. The ones in Computer Ports of Ultima IV have been around before the filter was put in place. Must be getting grandfathered in somehow. (I'd done a cursory check to see if things already existing matched the filter but I must have missed those.)
I'm not going to remove the filter as the spambots that are hitting it were ones posting anonymously so approving accounts won't have made any difference to them. -- Fenyx4 16:15, 28 December 2012 (PST)
I think that goes for all C64 pictures in the computer ports pages (and the C64 port page for Ultima VI) since I think I used the numbering sheme for all of these. So all of these need to be altered. Is there a way to make a search for the pictures that fall under the filter?--Tribun 16:51, 28 December 2012 (PST)
Since I can't move pictures myself, should a I report the problematic ones to you?--Tribun 05:24, 29 December 2012 (PST)